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Dreamweaver 1: Interface, Tables, and Images 
Once you’ve named, sliced, and exported your images in Photoshop, the next step is to 
place these images in an HTML file in Dreamweaver.  
 
Step 1: Download your images from your UWeb account. Make sure that the images go on 
the desktop and that they’re in a folder that’s called “images” (without the quotation 
marks).  
 
 
What is Dreamweaver? 
Dreamweaver is a Web-authoring program that allows you to create HTML (HyperText 
Markup Language) files without knowing HTML. All Web pages are composed of HTML code 
that tells the browser what to do in displaying the page. It’s pretty easy to learn HTML, but 
it’s even easier to let Dreamweaver write the code for you. Like FrontPage and Composer, 
Dreamweaver is a “WYSIWYG” editor; “WYSIWYG” is an acronym for "what you see is what 
you get," meaning that you design your HTML document visually rather than writing the 
code yourself.  
 
So you don’t need to know any HTML code at all and you can make a perfectly nice Web 
page. However, it is useful to know at least some of the basics of HTML in order to fix any 
problems that arise and to add HTML features that your WYSIWYG program doesn't support.  
If you’re interested in doing more Web pages, you might check out some of the HTML 
tutorials available on the Web.  
 
When you open Dreamweaver, you should have a new, blank file with lots of toolbars 
around it. For our purposes, you can close all of the toolbars except for the Properties 
Inspector and the Insert Toolbar.   
 

The Properties Inspector 
When you select an object in your Dreamweaver document, the Properties Inspector 
displays the properties of that object and allows you to make changes to the object. 
An object is any HTML element on your page, such as text, graphics, tables, lists, 
and forms. You select an object by highlighting it (text) or clicking on it (images, 
tables, lists, forms). 
 
The Insert Toolbar 
This toolbar allows you to insert different types of HTML objects, such as images, 
image maps, tables, horizontal lines, line breaks, rollovers, Flash plugins, and 
Shockwave plugins. Use the tabs to see different categories of objects. You can also 
access these commands via the Insert menu at the top of the screen. 

 
To open or close additional toolbars in Dreamweaver, go to Window (on the Menu across the 
top of the document) and select the toolbars you want opened or closed.  
 
Under the View menu you can change the view of your document so that you see just the 
code, just the design, or the code and the design together.  
 
 
Saving and Naming HTML Files  
It’s important—crucial, even—to save your HTML file in same location as your images. If the 
“images” folder you created is on the desktop, save your HTML file on the desktop.  
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It’s also important to give your file a name that does not have any spaces or odd characters 
in it (e.g., slashes, asterisks, quotation marks). Most homepages are named “index.html” or 
“index.htm”. Dreamweaver will give you “.htm” as the default extension; if you want to use 
“.html” you need to type this in yourself.  
 
Step 2: Save the file in the same location as your “images” folder—that is, on the desktop— 
naming the file “index.html” or “index.htm”.  
 
 
Setting Page Properties and Head Tags  
When you create a file in Dreamweaver, it’s a good idea to begin by giving the file a title, 
setting its background color, and providing meta tags for the file.  
 
The title is different from the name of your file. The title is what appears in the blue bar 
across the top of the browser window; it will not appear in the body of the page. You can 
have spaces and odd characters in your title.  
 
Step 3: Give your page a title by going to Modify > Page Properties and typing a title in the 
Title dialog box. An appropriate title for my homepage, for instance, would be “Madeleine 
Sorapure’s Homepage”.  
 
Under Modify > Page Properties, you can also set the background color for your page, along 
with the color of text, links, visited links, and active links. For this project, you’ll want your 
background color to be black. For your own homepage, choose the same background color 
as you used in the image you created in Photoshop.  
 
Note: in Dreamweaver, you’re only allowed to choose from 216 “web safe” colors. These 
are colors that will appear the same on Macs and PCs. If you want to use another color for 
your background, you’ll need to create a background image (we’ll get to that in a 
subsequent lesson).  
 
Step 4: Go to Modify > Page Properties and set the background color of your page.  
 
Note: Another way to select colors for background and text is to use one of Dreamweaver’s 
preset color schemes, located under Commands > Set Color Scheme.  
 
The next step is to set the Head tags for your page. Head tags contain information about a 
page that won’t appear on the page itself but will be read by Web search engines such as 
Google. You can specify keywords and a description of your Web page, along with other 
information, using the second and third icons under the Head tab of the Insert Toolbar.  
 
Keywords are used by search engines to identify the content of your web page; when a 
search engine displays a link to your page, the description is what appears under this link.   
 
Step 5: Using the Head tab on the Insert Toolbar, set the Keyword and Description tags for 
your page. Save your file (File > Save).  
 
 
Creating a Table 
Because spaces and tabs don’t work well in HTML, tables are used very often to align text 
and image on the page. In each cell of the table, you can type text, insert graphics, and 
even insert another table.  
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You insert the table by going to Insert > Table (or by using the Table tab in the Insert 
toolbar). In the resulting dialog box, you can set the following attributes of your table: the 
number of rows and columns, the width of the table (in pixels or in percentages), the border 
of the table, cell padding (the number of pixels between the cell content and the cell 
boundary), cell spacing (the number of pixels between each cell in the table). You can 
change these attributes after you’ve created the table by selecting the table (clicking on one 
of its edges) and using the Properties Inspector to make changes.  
 
Step 6:  Insert a table (Insert > Table) with 3 rows, 1 column. Set the width to 600 pixels, 
the border to 0, and cell padding and cell spacing to 0.  
 
Save the file. 
 
In Dreamweaver, tables have dotted outlines that don’t ultimately appear on your web 
page. To view the table without the outlines, go to View > Visual Aids, and unselect Table 
Borders. As you work, it’s helpful to have the outlines viewable so that you can see what 
you’re doing.  
 
 
Inserting Images 
You insert an image in your Dreamweaver document by clicking where in the table you want 
the image to be, and going to Insert > Image. Find the image in the resulting dialog box 
and click Open.  
 
Step 7: Click in the first row of the table and insert “name.jpg”.  
 
 
Inserting Rollover Images  
You insert a rollover image in your Dreamweaver document by clicking where in the table 
you want the image(s) to be, and going to Insert > Interactive Images > Rollover Image (in 
Dreamweaver MX—in earlier versions the command is Insert > Rollover Image).  
 
The resulting dialog box prompts you to give the image a name and then to select the 
original image and the rollover image. To select these images, click on browse, find the 
image, and click Open. There is also a box for “When clicked, go to URL”; here you type in 
the name of the web page that you would like this image to link to. In other words, when 
users click on the rollover image, it can take them to another web page, the name of which 
you specify in this dialog box.  
 
Step 8: Click in the second row of the table and go to Insert > Interactive Images > 
Rollover Image. For Name, type “resume”. For Original Image, click on Browse and find 
“resume_up.jpg”. For Rollover Image, click on Browse and find “resume_over.jpg”. For URL, 
type “resume.html”. 
  
Follow these steps for the other three sets of images, and save the file when you’re done. 
Test the page (F12) to be sure the rollovers work. 
 
 
Inserting Disjoint Rollover Images 
A disjoint rollover image is one where the effect of rolling over an image causes an image 
swap somewhere else on the screen. For this exercise, we’re going to add a disjoint rollover 
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to each button, so that the button itself will change and, in another location on the screen, 
text will appear that describes the link. 
 
For this exercise, you’ll need the following images (created and sliced in Photoshop):   
 

• a blank image (“text_blank.jpg”) 
• an image with text describing your resume (“text_resume.jpg”) 
• an image with text describing your writing (“text_writing.jpg”)  
• and an image with text describing your links (“text_links.jpg”).  

 
All of these images need to be exactly the same size (height and width). And all of the 
images should be in your “images” folder. 
 
Step 9: Click in the third row of the table and go to Insert > Image. Select the image 
“text_blank.jpg” and insert it in the row. You may want to center the image. 
 
With the image selected, type a name for it (“text”) in the Name box (the top left box) of 
the Properties Inspector.  
 
 
The next series of steps involve working with code, so make sure that you’ve got the Code 
window open (go to View > Code and Design). Essentially, what we’re going to do is add 
another image swap to the preexisting code. Looking in the Code window, find that section 
of the code that has your rollovers in it; it should look something like this (though with 
different spacing): 
 
<tr> 
    <td> 

<a href="resume.html" onMouseOut="MM_swapImgRestore()" 
onMouseOver="MM_swapImage('resume','','images/resume_over.jpg',1)"><img 
src="images/resume_up.jpg" name="resume" width="106" height="111" border="0"></a> 

 
<a href="wrotomg.html" onMouseOut="MM_swapImgRestore()" 
onMouseOver="MM_swapImage('writing','','images/writing_over.jpg', 1)"><img 
src="images/writing_up.jpg" name="writing" width="106" height="111" border="0"></a> 
 
<a href="links.html" onMouseOut="MM_swapImgRestore()" 
onMouseOver="MM_swapImage('mylinks','','images/links_over.jpg',1)"><img src="images/links_up.jpg" 
name="mylinks" width="105" height="111" border="0"></a> 
 
<a href="contact.html" onMouseOut="MM_swapImgRestore()" 
onMouseOver="MM_swapImage('contact','','images/contact_over.jpg',1)"><img 
src="images/contact_up.jpg" name="contact" width="101" height="111" border="0"></a> 

       </td> 
  </tr> 
 
You’ll need to insert a small bit of code into the first three <a href> tags. Here goes! 
 
  
Step 10: Find the part of the code that says  
 

onMouseOver=”MM_swap_Image(‘resume’,’’,’images/resume_over.jpg’,1)” 
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After the last comma and before the “1”, insert the following code: 
 
 ‘text’,’’,’images/text_resume.jpg’, 
 
Next, find the part of the code that says  
 

onMouseOver=”MM_swap_Image(‘writing’,’’,’images/writing_over.jpg’,1)” 
 
After the last comma and before the “1”, insert the following code: 
 
 ‘text’,’’,’images/text_writing.jpg’ 
 
Finally, find the part of the code that says 
 

onMouseOver=”MM_swap_Image(‘mylinks’,’’,’images/links_over.jpg’,1)” 
 
After the last comma and before the “1”, insert the following code: 
 
 ‘text’,’’,’images/text_links.jpg’ 
 
Go to File > Save, and test the page to be sure the rollovers work (F12). 
 
 
Adjusting and Positioning the Table 
You can adjust the width of the table so that it fits the size of the images exactly. Do this by 
positioning your mouse over the left edge of the table; the cursor should turn into two bars 
with arrows pointing in both directions. Click and pull on the table to adjust the width.  
 
You position the table by selecting it and specifying its position (align left, center, align 
right) in the Properties Inspector. To select the table, position your mouse over the bottom 
edge of the table; the cursor should turn into four arrows. Click on the table. In the 
Properties Inspector, use the Align option to position the table.  
 
Step 9: Adjust the width of the table so that it fits the size of the images exactly. Center the 
table on the page. Move the table down on the page by clicking in front of the table and 
hitting return several times. 
  
Save the file. 
 
 
Posting your Page on the Web  
After you’ve saved the file, upload it to your uweb folder in your UMail account. You must 
also send the “images” folder that you created on the Desktop to your uweb folder. Upload 
the entire “images” folder—in other words, don’t send each individual image.  
 
To view the page you just created, go to the following URL: 

 
http://www.uweb.ucsb.edu/~yourlogin/ 
 

where “yourlogin” is your login for your umail account (whatever comes before the @ sign 
in your umail address).  


